Задать вопрос

Написать программу в паскале: Дано трехзначное число. Найти число, полученное перестановкой первой и третьей цифры заданного числа.

+1
Ответы (1)
  1. program zz1;

    var s, n, k, p:integer; / / задаем переменные целого типа

    begin

    write (' введите натуральное трехзначное число ');

    read (n); / / вводим с клавиатуры число трехзначного числа

    k:=n mod 10; / / получаем последнюю цифру трехзначного числа

    p:=n div 100; / / получаем первую цифру трехзначного числа

    s: = (n mod 100) div 10; / / получаем вторую цифру

    n:=k * 100 + s * 10 + p; / / формируем новое число, поменяв местами первую и последнюю цифры

    writeln (' полученное перестановкой первой и третьей цифры число = ', n); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу в паскале: Дано трехзначное число. Найти число, полученное перестановкой первой и третьей цифры заданного числа. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное трехзначное число N. Составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц исходного числа к нему же слева (в разряд тысяч). Используя текстовые файлы input, output.
Ответы (1)
Дано трехзначное число. Напишите программу, которая опеределяет Есть ли среди цифр заданного целого трехзначного числа одинаковые
Ответы (1)
Написать программу в Паскале Найти все натуральные числа, не превосходящие заданного n, которые делятся на каждую из своих цифр.
Ответы (1)
Написать в программе Паскаль: Дано целое число. Если оно положительное и трехзначное, найти сумму первой и третьей цифры этого числа, в противном случае сообщить, что число нам не подходит.
Ответы (1)
Написать программу. Дано четырехзначное число. Определить, равен ли квадрат первой цифры кубу третьей цифры этого числа.
Ответы (1)