Задать вопрос
12 января, 01:25

Дано натуральное четырехзначное число, верно ли, что все его цифры различны? Написать программу.

+4
Ответы (1)
  1. 12 января, 03:33
    0
    Программа на С++.

    #include

    using namespace std;

    int main () {

    setlocale (LC_ALL, "Russian"); / / перевод консоли на русский язык.

    int a; / /само число.

    int a1; / / тысячный разряд.

    int a2; / / сотый разряд.

    int a3; / / десятки.

    int a4; / / единицы.

    cout<<"Введите четырехзначное число"<
    cin>>a; / /ввод числа с клавиатуры.

    a1 = a / 1000;

    a2 = (a/100) % 10;

    a3 = (a / 10) % 10;

    a4 = a % 10;

    if (a1 = = a2 or a1 = = a3 or a1 = = a4 or a2 = = a3 or a2 = = a4 or a3 = = a4) {

    cout<<"В заданном числе есть равные цифры.";

    }

    else {

    cout<<"Все цифры заданного числа различны.";

    }

    return 0;

    }
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано натуральное четырехзначное число, верно ли, что все его цифры различны? Написать программу. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)
Дано натуральное трехзначное число N. Составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц исходного числа к нему же слева (в разряд тысяч). Используя текстовые файлы input, output.
Ответы (1)
Написать программу. Дано четырехзначное число. Определить, равен ли квадрат первой цифры кубу третьей цифры этого числа.
Ответы (1)
Дано натуральное число. Верно ли, что в нем нет цифры b? Написать программу на паскале не используя boolean массивы и строковые типы
Ответы (1)