Задать вопрос

Массив А (20) заполнить случайными целыми числами в диапазоне от - 30 до 30. Найти количество N попарных произведений А (I) * А (I+1) <0. Вывести А, все попарные произведения А (I) * А (I+1), N.

+1
Ответы (1)
  1. 13 мая, 14:42
    0
    program zz1;

    var mas:array[1 ... 20] of integer;

    i, k:integer;

    begin

    for i:=1 to 20 do

    mas[i]:=random (61) - 30; / /заполняем массив двадцатью рандомными числами из указанного диапазона

    for i:=1 to 20 do

    write (mas[i],' '); / /выводим массив на экран

    writeln; / /переходим на новую строку для вывода

    for i:=1 to 19 do

    if (mas[i]*mas[i+1]<0) then begin writeln (mas[i],'*', mas[i+1],'=', mas[i]*mas[i+1]); k:=k+1; end; / /проверяем условие, считаем количество нужных произведений

    writeln ('количество найденных произведений - ', k); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Массив А (20) заполнить случайными целыми числами в диапазоне от - 30 до 30. Найти количество N попарных произведений А (I) * А (I+1) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)
Составьте программу которая заполняет массив b 1 ... 8 случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными значениями пример ввода: исходный массив: 10 2 4 1 3 5 7 8 количество пар чётных элементов =
Ответы (1)