Задать вопрос

Написать программу в Паскале, массив который меняет 5 и 3 строку.

+4
Ответы (1)
  1. 4 апреля, 04:34
    0
    program zz1;

    const n = 8;

    b = 7; / / задаем количество элементов в массиве

    var i, j, k:integer; / / задаем переменные целого типа

    m:array [1 ... n, 1 ... b] of integer;

    begin

    for i:=1 to n do

    for j:=1 to b do / / получаем числа и записываем их в массив

    m[i, j]:=random (101) - 50;

    for i:=1 to n do / / выводим исходный массив на экран

    begin

    for j:=1 to b do

    write (m[i, j]:4);

    writeln;

    end;

    writeln;

    for j:=1 to b do

    begin

    k:=m[3, j]; m[3, j]:=m[5, j]; m[5, j]:=k;

    end;

    for i:=1 to n do / / выводим полученный массив на экран

    begin

    for j:=1 to b do

    write (m[i, j]:4);

    writeln;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу в Паскале, массив который меняет 5 и 3 строку. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Помогите написать программу в паскале. Заполните массив из N элементов случайными числами в интервале [1, N] так, чтобы в массив обязательно вошли все числа от 1 до N (постройте случайную перестановку). Пример: Массив: 3 2 1 4 5
Ответы (1)
1) Как можно описать на Паскале 1) Как можно описать на Паскале массив, в котором будет храниться значения численности населения Москвы к концу каждого года XX века?2) Вы приобрели котёнка. Каждый вечер вы определяете его вес с помощью весов.
Ответы (1)
Составить программу, которая меняет элементы массива на противоположные по знаку, массив заполняется с клавиатуры. Решить задачу на паскале.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)