Задать вопрос

Требуется использовать язык Паскаль Даны три целых числа A, B, C. Значения чисел вводятся с клавиатуры. Определить количество нулей среди данных чисел. Результат вывести на экран.

+3
Ответы (1)
  1. 9 октября, 16:29
    0
    Program abc;

    var

    a, b, c: real;

    k: integer;

    begin

    writeln ('Введите числа a, b, c:');

    readln (a, b, c);

    if a=0 then

    if b=0 then

    if c=0 then writeln ('3') else writeln ('2')

    else if c=0 then writeln ('2') else writeln ('1')

    else if b=0 then if c=0 then writeln ('2') else writeln ('1')

    else if c=0 then writeln ('1') else writeln ('0');

    readln

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Требуется использовать язык Паскаль Даны три целых числа A, B, C. Значения чисел вводятся с клавиатуры. Определить количество нулей среди ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1) Сколько значащих нулей в двоичной записи десятичного числа 503? 2). Для каждого из перечисленных ниже десятичных чисел построили двоичную запись. Укажите число, двоичная запись которого содержит наибольшее количество значащих нулей.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.
Ответы (1)