Задать вопрос
24 декабря, 02:20

Задачи по теме массив 1. В массиве хранятся сведения об оценках 25 учеников по химии. Определить количество неуспевающих по химии учеников. 2. В мвссиве хранятся сведения об общей стоимости товаров, проданных фирмой за каждый день марта. Определить количество дней, в которые стоимость проданных товаров превысила значение S.

+1
Ответы (1)
  1. 24 декабря, 04:58
    0
    1.

    program zz1;

    const n = 25; / / задаем количество элементов в массиве

    var i, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (5) + 1;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if m[i] < 3 then k:=k + 1;

    writeln (' количество неуспевающих учеников = ', k); / / выводим ответ

    end.

    2.

    program zz1;

    const n = 31; / / задаем количество элементов в массиве

    var i, s, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    write (' введите заданное число ');

    read (s);

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (21) + 10;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if m[i] > s then k:=k + 1;

    writeln (' количество дней, в которые стоимость проданных товаров превысила значение S = ', k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Задачи по теме массив 1. В массиве хранятся сведения об оценках 25 учеников по химии. Определить количество неуспевающих по химии учеников. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
В массиве хранятся сведения о количестве осадков, выпавших за 10 дней июня. Написать программу, которая определяет общее количество осадков за 10 дней. Массив должен вводиться во время работы программы.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) В массиве хранятся сведения о количестве осадков, выпавших за январь. Определить: а) Общее количество осадков за январь;
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
В массиве хранятся сведения о количестве осадков, выпавших за каждый день января. Определить в какие дни осадков не было. (Решите в Pascal).
Ответы (1)