Задать вопрос

Заполнить массив из 15 элементов случайным образом. Вещественными значениями x (22 больше или равно х < 23).

+4
Ответы (1)
  1. 23 июня, 07:38
    0
    program zz1;

    const n = 15; / / задаем количество элементов в массиве

    var i:integer; / / задаем переменную целого типа для цикла

    m:array [1 ... n] of real; / / описываем массив вещественных чисел

    begin

    for i:=1 to n do / / получаем n чисел случайных в заданном диапазоне и записываем их в массив

    m[i]:=random () + 22;

    for i:=1 to n do / / выводим полученный массив на экран в формате семь знаков для всего числа и два знака после десятичной точки

    write (m[i]:7:2);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Заполнить массив из 15 элементов случайным образом. Вещественными значениями x (22 больше или равно х < 23). ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
Задать массив из 8 элементов целого типа. Заполнить массив случайными значениями из интервала (-10; 10) и вывести массив. Найти сумму и количество четных, а также произведение и количество нечетных значений элементов массива.
Ответы (1)
Массив целых чисел из 15 элементов. Заполнить случайным образом. Упорядочить массив по убыванию. Подсчитать количество элементов больше 10, вывести результат.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)