Задать вопрос
27 августа, 21:46

Каков будет результат выполнения фрагмента программы pred ('D') а) А б) С в) d г) Е

+5
Ответы (1)
  1. 27 августа, 22:05
    0
    Пусть s - результат выполнения команды pred ('D'). Это будет величина типа char (символьная величина; занимает 1 байт памяти и хранит 1 символ; значение величины типа char заключается в апострофы). Составим программу нахождения значения величины s на языке программирования Pascal ABC:

    program zadacha;

    uses crt;

    var s: char; {Описание искомой величины s}

    begin

    s:=pred ('D'); {Нахождение искомой величины s }

    writeln ('s=', s); {Вывод искомой величины s на экран}

    end.

    После выполнения этой программы получим, что правильный ответ будет под пунктом б) С.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Каков будет результат выполнения фрагмента программы pred ('D') а) А б) С в) d г) Е ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
Что выведется на экран в результате выполнения фрагмента программы: s:=0; FOR j:=1 TO 3 DO s:=s+2*j; write (' j=', j, ' s=', s) Что выведется на экран в результате выполнения фрагмента программы: p:=1; FOR k:=1 TO 5 DObegin p:=p*k; end;
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a: = 42; b: = 14; a:=a div b; b:=a*b a:=b div a 2) Определите значение целочисленных переменных x, y и t и b после выполнения фрагмента программы: x:=5; y:=7;
Ответы (1)