Задать вопрос
19 ноября, 15:14

Составьте программу вычисления 1+2+4+8 + ... + 2 (в 10 степени)

+4
Ответы (1)
  1. 19 ноября, 17:23
    0
    var a, b, sum:longint;

    begin

    b:=1;

    for a:=0 to 10 do begin

    sum:=sum+b;

    b:=b*2;

    end;

    writeln (sum);

    end.

    (Если на Паскале, то вот это должно прокатить))
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу вычисления 1+2+4+8 + ... + 2 (в 10 степени) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
напишите программу для вычисления n-ной степени числа х. вычисления описать вкаждым из трех вариантов оператора цикла
Ответы (1)
Составьте программу для вычисления значения функции y = sinx + 1/x, для которой значение аргумента x введите с клавиатуры. (на Паскале) Наладить программу так, чтобы x = 5; y = - 0.758924
Ответы (1)
Составить программу вычисления значения функции y = 3x в 6 степени - 6x в 2 степени-7, используя оператор ввода данных b с экрана монитора и вывода y на экран
Ответы (1)
Составить программу для вычисления площади треугольника с координатами вершин (x1, y1), (x2, y2), (x3, y3), используя формулу для вычисления расстояния между двумя точками на плоскости. Площадь вычисляется по формуле Герона
Ответы (1)