Задать вопрос

1) Известны длины сторон треугольника a, b, c. Напишите программу, вычисляющую площадь этого треугольника. 2) Если сумма налога исчисляется в рублях и копейках, то налоговая служба округляет ее до ближайшего рубля (до 50 копеек - с недостатком, свыше 50 копеек (включая 50) - с избытком). Используйте компьютер, чтобы ввести точную сумму налога и вывести, сколько следует уплатить.

+3
Ответы (1)
  1. 30 марта, 05:49
    0
    1) program zz1;

    var a, b, c, S, p, d:real; / /задаем переменные не целого типа

    begin

    write ('введите первую сторону треугольника ');

    read (a);

    write ('введите вторую сторону треугольника ');

    read (b);

    write ('введите третью сторону треугольника ');

    read (c);

    d: = (a+b+c) / 2; / /находим полу периметр треугольника

    if (a+b>c) or (a+c>b) or (c+b>a) / /проверяем на существование треугольника, если существует, то вычисляем площадь

    then begin s:=sqrt (d * (d-a) * (d-b) * (d-c)); write ('площадь треугольника = ', s:5:2); end

    else write ('треугольник не существует ');

    end.

    2) program zz1;

    var a, b:integer; / / вводим переменные целого типа

    begin

    write (' введите сумму налога в рублях '); / / вводим с клавиатуры число a

    read (a);

    write (' введите сумму налога в копейках '); / / вводим с клавиатуры число b

    read (b);

    if b > = 50 / / проверяем условие

    then a:=a + 1;

    write (' необходимо заплатить = ', a, ' рублей'); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Известны длины сторон треугольника a, b, c. Напишите программу, вычисляющую площадь этого треугольника. 2) Если сумма налога исчисляется ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Если сумма налога исчисляется в рублях и копейках, то налоговая служба округляет ее до ближайшего рубля (до 50 копеек - с недостатком, свыше 50 копеек (включая 50) - с избытком).
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Ввести число от 5 до 9. Вывести его значение словом. Составить программу для решения приведенного ниже задания двумя способами, используя: а) команду выбора case; б) команду if. Ввести число от 5 до 9. Вывести его значение словом.
Ответы (1)
1. написать программу, вычисляющую значение функции y=x-24 2. написать программу, вычисляющую значение функции (y=f (x)) y=x-2, если x>0, y=0, если x=0, y=x*x, если x
Ответы (1)