Задать вопрос
13 февраля, 15:21

Задача на тему цикл с параметром Паскаль. Определить среди 10 чисел какое из них наибольшее и вывести порядковый номер этого числа.

+2
Ответы (1)
  1. 13 февраля, 18:43
    0
    program zz1;

    var i, s, n, max:integer; / / задаем переменные целого типа

    begin

    max:=0; / / задаем начальное значение для наибольшего

    for i:=1 to 10 do / / организуем цикл на десять повторений

    begin

    read (n); / / вводим очередное число

    if n > max then begin max:=n; s:=i; end; / / проверяем условие на максимальное и запоминаем его номер

    end;

    writeln (' наибольшее число среди введенных = ', max, ' его номер = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Задача на тему цикл с параметром Паскаль. Определить среди 10 чисел какое из них наибольшее и вывести порядковый номер этого числа. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Цикл с параметром паскаль вывести все трехзначные числа оканчивающиеся на 13; 42
Ответы (1)
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Факториалом числа 5 (обозначается 5!) называется значение следующего выражения: f=1*2*3*4*5. Составьте программу, которая запросив у пользователя целое число n, вычислит значение факториала числа. (Линейное программирование, цикл с параметром)
Ответы (1)