Задать вопрос

Составить программу для последовательного произведения вводимой с клавиатуры целых чисел предусмотреть выход из произведения при вводе - 100

+5
Ответы (1)
  1. 5 сентября, 16:23
    0
    var

    a, c : integer; / / объявление переменных целочисленного типа.

    begin

    c:=1;

    writeln ('введите последовательность целых чисел, окончание ввода - 100'); / / вывод строки.

    repeat / / начало цикла.

    read (a); / / считываем введенное число.

    if a - 100 then / / если число не равно - 100, то считаем произведение.

    c : = c * a;

    until a = - 100; / / если число равно - 100, то выходим из цикла.

    write ('Произведение всех чисел введенной последовательности равно: ', c); / / вывод строки.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу для последовательного произведения вводимой с клавиатуры целых чисел предусмотреть выход из произведения при вводе - 100 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности дробных чисел. Количество чисел должно задаваться во время работы программы. (цикл для) (паскаль)
Ответы (1)
Напишите программу которая выводит на экран слово "женский" при вводе символа Ж и словa " мужской" при вводе символа М
Ответы (1)
Требовалось написать программу, при выполнении которой с клавиатуры вводится натуральное число, не превосходящее 10^8, и выводится его первая цифра.
Ответы (1)
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)