Задать вопрос

Найти все нечетные элементы массива целых чисел на паскале

+4
Ответы (1)
  1. 18 апреля, 19:00
    0
    var

    i, n: integer; / / объявляем переменные целочисленного типа.

    arr: array [1 ... 10] of integer; / / объявляем массив, размерностью 10.

    s, s1 : string; / / объявляем переменные строкового типа.

    begin

    for i : = 1 to 10 do / / начало цикла.

    begin

    arr[i] : = random (-20, 20); / / заполняем элемент массива числом из диапазона - 20; 20.

    s : = s + arr[i] + ' '; / / записываем исходный массив в одну строку.

    if (arr[i] mod 2 0)

    then s1 : = s1 + arr[i] + ' '; / / записываем массив нечетных элементов в одну строку.

    end;

    writeln ('Исходный массив: ', s); / / вывод на экран строки.

    writeln ('Нечетные элементы массива: ', s1); / / вывод на экран строки.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти все нечетные элементы массива целых чисел на паскале ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Создать два одномерных массива, состоящих из целых чисел. Элементы массива вводятся с клавиатуры. В первом массиве найти номер первого нечетного элемента массива. Во втором массиве найти первый четный элемент массива.
Ответы (1)