Задать вопрос

Подсчитать количество целых среди чисел а, b, с. Составить программу.

+2
Ответы (1)
  1. 15 марта, 21:51
    0
    program zz1;

    var a, b, c, d:real; / / задаем переменные не целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье число '); / / вводим с клавиатуры третье число

    read (c);

    if frac (a) = 0 then d:=d + 1; / / проверяем, есть ли у числа что-нибудь после запятой

    if frac (b) = 0 then d:=d + 1;

    if frac (c) = 0 then d:=d + 1;

    writeln (' количество целых среди введенных чисел = ', d); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Подсчитать количество целых среди чисел а, b, с. Составить программу. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) В диапазоне от 0 до 100 подсчитать количество чисел оканчивающихся на 3.2) В диапазоне от 0 до 50 подсчитать количество чисел сумма цифр которых равна 3.
Ответы (1)
Составить программу для решения следующей задачи: Дан массив А целых чисел в интервале [-10 ... 10]. Подсчитать в нем количество элементов, равных 5
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Написать программу. Ввести одномерный массив из целых чисел. Подсчитать во сколько раз сумма четных чисел массива превосходит среднее арифметическое всех чисел массива?
Ответы (1)