Задать вопрос

1. Определите значение переменной S после выполнения операторов:i:=0; S:=0While i<5 doBegini:=i+2; S:=S+i*iEnd; 2. Тело цикла While для вычисления значений функций f (x) = x4, на отрезке [-5,5] с шагом 10 будет иметь вид:f: = x+x+x+x; x:=x+10; writeln (f, x); f:=x4; x:=x+10; writeln (f, x); f: = x*x*x*x; x=x+0.10; writeln (f, x); f: = x*x*x*x; x:=x+10; writeln (f, x);

+3
Ответы (1)
  1. 26 мая, 01:57
    0
    1.

    i:=0

    S:=0

    i<5 0 < 5 (Истина)

    i:=i + 2 (2 = 0 + 2)

    S:=S+i*i (4 = 0 + 2 * 2)

    i<5 2 < 5 (Истина)

    i:=i + 2 (4 = 2 + 2)

    S:=S+i*i (20 = 4 + 4 * 4)

    i<5 4 < 5 (Истина)

    i:=i + 2 (6 = 4 + 2)

    S:=S+i*i (56 = 20 + 6 * 6)

    i<5 6 < 5 (Ложь)

    Ответ: значение переменной S после выполнения операторов равно 56.

    2.

    f: = x*x*x*x; x:=x+10; writeln (f, x);
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Определите значение переменной S после выполнения операторов:i:=0; S:=0While i ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
Запишите на алгоритмическом языке алгоритм, в результате которого переменной а будет присвоено значение переменной Ь, переменной b - значение переменной с, а переменной с - значение переменной а. Используйте не более одной промежуточной переменной.
Ответы (1)
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
Определите значение переменной S после выполнения опера-торов:i:=0; S:=0While i
Ответы (1)