Задать вопрос

Написать программу в паскале: Даны целое n>0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. Найти величину наибольшего среди отрицательных чисел этой последовательности.

+5
Ответы (1)
  1. 25 апреля, 22:48
    0
    program zz1;

    var a, n, i, max:integer; / / задаем переменные целого типа

    begin

    write (' введите n '); / / вводим с клавиатуры число

    read (n);

    max: = - 10000; / / задаем начальное значение для максимального

    for i:=1 to n do

    begin

    read (a); / / вводим очередное число последовательности

    if a max then max: = a; / / проверяем, если число больше максимального, то записываем его в максимальное

    end;

    write (' максимальное число среди отрицательных чисел последовательности = ', max); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу в паскале: Даны целое n>0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего - в куб и нахождения среднего арифметического полученных значений. 2.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Напишите программу которая в последовательности натуральных чисел определяет максимальное четное число, программа получает на вход целые числа, кол во введеных чисел неизвестн, последовательность чисел заканчивается числом 0 (горантируя, что хотя бы
Ответы (1)
Напишите программу в паскале, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Вводится последовательность 14 чисел. Определить сколько среди них не отрицательных и сколько отрицательных чисел. Составьте алгоритм на Паскале с циклом WHILE
Ответы (1)