Задать вопрос

Написать программу которая выводит на экран числа 897, 910, 923, 936,948, 961 сначала в столбик, а потом в строку. (Pascal)

+1
Ответы (1)
  1. 9 октября, 16:00
    0
    Четыре первых числа можно представить в виде 897 + i*13, а два последних в виде 897 + i*13 - 1, из-за чего пришлось вводить условие по параметру i.

    program wrtln_wrt;

    begin

    for i: integer: = 0 to 5 do

    if i < 4 then writeln (897 + i * 13) else writeln (897 + i * 13 - 1);

    writeln ();

    for i:integer: = 0 to 5 do

    if i < 4 then write ((897 + i * 13) : 4) else write ((897 + i * 13 - 1) : 4)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу которая выводит на экран числа 897, 910, 923, 936,948, 961 сначала в столбик, а потом в строку. (Pascal) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы