Задать вопрос
29 декабря, 23:31

Требуется определить, является ли данный год високосным. (Напомним, что год является високосным, если его номер кратен 4, но не кратен 100, а также если он кратен 400.) Примеры Входные данные 2007 Выходные данные NO Входные данные 2000 Выходные данные YES

+5
Ответы (1)
  1. 29 декабря, 23:45
    0
    program zz1;

    var y: integer; / / задаем переменную целого типа

    begin

    write (' введите год '); / / вводим с клавиатуры номер года, который будем проверять

    read (y);

    if (y mod 4 0) or (y mod 100 = 0) and (y mod 400 0) / / проверяем, если год не соответствует условию высокосного года, то

    then

    writeln ('NO') / / выводим один ответ

    else

    writeln ('YES'); / / иначе, выводим другой ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Требуется определить, является ли данный год високосным. (Напомним, что год является високосным, если его номер кратен 4, но не кратен 100, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
По данному натуральному n вычислите сумму 12+22 + ... + n2. Входные данные Вводится единственное натуральное число n, не превосходящее 100 Выходные данные Необходимо вывести вычисленную сумму. Примеры входные данные 2 выходные данные 5
Ответы (1)
Дано натуральное число. Выведите его последнюю цифру. Входные данные Вводится единственное число (гарантируется, что оно не превышает 10000). Выходные данные Выведите ответ на задачу. Примеры входные данные 249 выходные данные 9
Ответы (1)
Задача. Год является високосным, если его номер кратен 4, однако из кратных 100 високосными являются лишь кратные 400. Например 1700,1800,1900-не високосные, а 2000 високосный. Дано натуральное число n.
Ответы (1)
Написать на Паскале Четные числа Входные данные Вводятся целые числа a и b. Гарантируется, что a не превосходит b Выходные данные Выведите (через пробел) все четные числа от a до b (включительно). входные данные 2 5 выходные данные 2 4
Ответы (1)