Задать вопрос

Задача. Год является високосным, если его номер кратен 4, однако из кратных 100 високосными являются лишь кратные 400. Например 1700,1800,1900-не високосные, а 2000 високосный. Дано натуральное число n. Определить, является ли високосным год с таким номером? Решить на паскале, уровень 8 класса!

+3
Ответы (1)
  1. program leap_year;

    var n: integer;

    begin

    writeln ('Введите номер года');

    readln (n);

    if (n mod 4 = 0) and (n mod 100 0) then writeln ('Это високосный год');

    if (n mod 400 = 0) then writeln ('Это високосный год');

    if (n mod 100 = 0) and (n mod 400 0) then writeln ('Это не високосный год');

    if n mod 4 0 then writeln ('Это не високосный год')

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Задача. Год является високосным, если его номер кратен 4, однако из кратных 100 високосными являются лишь кратные 400. Например ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Требуется определить, является ли данный год високосным. (Напомним, что год является високосным, если его номер кратен 4, но не кратен 100, а также если он кратен 400.
Ответы (1)
Составить программу, которая в зависимости от порядкового номера месяца выводит на экран количество дней в этом месяце. Рассмотреть два случая: 1. год високосный. 2. год не является високосным
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Дан номер года. Определить количество дней в этом году, если високосный год делится на 4, за исключением тех годов, которые делятся на 100 и не делятся на 400. Решить нужно с помощью case.
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)