Задать вопрос

Дано все 3-х значные числа Найти сумму и колличество чисел, кратных 9.

+2
Ответы (1)
  1. 19 апреля, 16:29
    0
    program zz1;

    var i, s, k:integer; / / вводим переменные целого типа

    begin

    for i:=100 to 999 do / / организуем цикл, в котором переберем все трехзначные числа

    if i mod 9 = 0 / / проверяем, если трехзначное число кратно девяти, то

    then begin s:=s + i; k:=k+1; end; / / вычисляем сумму таких чисел и их количество

    / / выводим ответ

    writeln (' сумма трехзначных чисел кратных девяти = ', s);

    writeln (' количество трехзначных чисел кратных девяти = ', k);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано все 3-х значные числа Найти сумму и колличество чисел, кратных 9. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4.
Ответы (1)
1. найти сумму первых 10 чисел, кратных 7; 2. вывести на экран 11 первых чисел кратных 5; 3. составить программу рисования 18 прямоугольников синего цвета, координаты которых определяется случайным образом, а стороны равны а=140, b=40.
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)