Задать вопрос

Составить программу в Pascal 1) в строке, введенной с клавиатуры, все буквы И заменить на % 2) из строки, введенной с клавиатуры, удалить все символы, начиная с середины.

+5
Ответы (1)
  1. 5 апреля, 21:05
    0
    1) program zz1;

    var s:string; / / задаем переменную строкового типа

    i:integer; / / задаем переменную целого типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры строку

    for i:=1 to length (s) do / / организуем цикл, в котором переберем все символы от первого до последнего

    begin

    if s[i] = 'И' then s[i]:='%'; / / производим замену

    end;

    write ('полученная строка = ', s);

    end.

    2) program zz1;

    var s:string; / / задаем переменную строкового типа

    i, k:integer; / / задаем переменную целого типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры строку

    k: = length (s) div 2;

    delete (s, k+1, length (s) - k);

    write ('полученная строка = ', s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу в Pascal 1) в строке, введенной с клавиатуры, все буквы И заменить на % 2) из строки, введенной с клавиатуры, удалить ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике