Задать вопрос

С клавиатуры одной строкой вводят имя и фамилию. Составьте программу, которая определяет, есть ли во введенной строке заданный символ

+1
Ответы (1)
  1. 2 февраля, 18:30
    0
    program zz1;

    var

    a, e: string; / / задаем переменные строкового типа

    b, c: integer;

    begin

    write (' введите имя и фамилию одной строкой ');

    readln (a);

    write (' введите заданный символ ');

    readln (e);

    b : = length (a); / / находим длину всей исходной строки

    c: = pos (e, a); / / находим позицию заданного символа в исходной строке

    if c = 0 then writeln (' заданного символа в исходной строке имени и фамилии нет ')

    else writeln (' заданный символ в исходной строке имени и фамилии есть '); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «С клавиатуры одной строкой вводят имя и фамилию. Составьте программу, которая определяет, есть ли во введенной строке заданный символ ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы