Задать вопрос

Какое значение получит переменная z после исполнения следующего фрагмента программы? z : = 5; x : = 1; if z > 0 then z : = 2 * z else x : = 10; if x = 0 then z : = - 2 else z : = 9; if (sqrt (z) = 3) and (x > 1) then z : = z - 8 else z : = 3 * x;

+3
Ответы (1)
  1. 23 апреля, 00:36
    0
    z : = 5; x : = 1; / /сейчас z=5, x=1

    if z > 0 then z : = 2 * z / /истина, z=10, x=1

    else x : = 10;

    if x = 0 then z : = - 2 / /ложь, исполняется другая ветка

    else z : = 9; / /z=9, x=1

    if (sqrt (z) = 3) and (x > 1) then z : = z - 8 / /ложь, исполняется другая ветка

    else z : = 3 * x; / /z=3

    Ответ: z=3
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Какое значение получит переменная z после исполнения следующего фрагмента программы? z : = 5; x : = 1; if z > 0 then z : = 2 * z else x : = ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)