Задать вопрос

Вводятся 10 чисел. Вывести на экран суммы положительных и отрицательных чисел и их количество

+1
Ответы (1)
  1. 24 августа, 14:14
    0
    program zz1;

    var a, b1, b2, n1, n2, i:integer; / / задаем переменные целого типа

    begin

    for i:=1 to 10 do

    begin

    read (a); / / вводим число

    if a > 0 then begin n1:=n1 + a; b1:=b1 + 1; end; / / проверяем, если введенное число больше нуля, то добавляем его к сумме и считаем количество

    if a < 0 then begin n2:=n2 + a; b2:=b2 + 1; end; / / проверяем, если введенное число меньше нуля, то добавляем его к сумме и считаем количество

    end;

    write (' сумма положительных чисел = ', n1, ' их количество = ', b1); / / выводим ответ

    write (' сумма отрицательных чисел = ', n2, ' их количество = ', b2); / /

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вводятся 10 чисел. Вывести на экран суммы положительных и отрицательных чисел и их количество ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.
Ответы (1)
Массив состоит из 20 целых положительных и отрицательных чисел, каждое из которых находится в пределах от 2 до 12. Вывести на экран сначала отрицательные, а затем положительные числа.
Ответы (1)
По заданному числу K (от 0 до 10) вывести его название. Например при K=2 вывести на экран , при K=3 вывести на экран и т. д
Ответы (1)