Задать вопрос

Напишите программу, которая в последовательности чисел определяет минимальное число.

+3
Ответы (1)
  1. 8 ноября, 20:23
    0
    program zz1;

    var a, n, i, min:integer; / / задаем переменные целого типа

    begin

    write (' введите n '); / / вводим с клавиатуры чисел в исходной последовательности

    read (n);

    min:=100000; / / задаем начальное значение для минимального числа

    for i:=1 to n do

    begin

    read (a); / / вводим очередное число последовательности

    if a < min then min:=a; / / проверяем, если введенное число больше минимального, то записываем его в минимальное

    end;

    write (' минимальное число = ', min); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая в последовательности чисел определяет минимальное число. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (1)
1. напишите программу, которая для последовательности натуральных чисел определяет их сумму. Программа получает на вход количество чисел в последовательности и сами числа 2. Измените программу так, чтобы определялось произведение чисел. 3.
Ответы (1)
1. напишите программу которая в последовательности натуральных чисел определяет сумму чисел кратных семи и оканчивающихся на один количество не известно 2.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)