Задать вопрос

Дан массив из 20 целых чисел заполненный случайным образом от 10 до 99. Найти сумму десятков (пример: первых чисел из 19 и 23 найти сумму 1 и 2)

+2
Ответы (1)
  1. 18 января, 06:51
    0
    Const n=20;

    var a:array[1 ... n] of integer;

    i, s:integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (90) + 10;

    write (a[i]:3);

    end;

    writeln;

    s:=0;

    for i:=1 to n do

    s:=s+a[i] div 10;

    writeln ('s = ', s);

    end.

    Второй вариант выполнения:

    Program sum1;

    var a:array[1 ... 20] of integer; k, i:integer;

    begin

    k:=0;

    randomize;

    for i:=1 to 20 do

    begin

    a[i]:=random (90) + 10;

    write (a[i],' ');

    k:=k + a[i] div 10;

    end;

    readln;

    write ('summa desyatkov = ', k);

    readln;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив из 20 целых чисел заполненный случайным образом от 10 до 99. Найти сумму десятков (пример: первых чисел из 19 и 23 найти сумму 1 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
Дан одномерный массив целых чисел, заполненный случайным образом числами из промежутка [-40, 30]. Массив данных хранится в файле. Удалить из него все элементы, которые состоят из одинаковых цифр. Результат записать в другой файл.
Ответы (1)
Дан двумерный массив размером n*m заполненный случайным образом. получить одномерный массив, элементами которого являются сумма наименьшего и наибольшего элементов соответственной строки двумерного массива (в паскале)
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
Дан массив целых чисел a (n) (n=15) заполненный случайным образом числами из промежутка [-20,50]. Заменить нулем четные по значению элементы данного массива
Ответы (1)