Задать вопрос
2 сентября, 18:04

Написать программу в паскале: Дано натуральное число n. Заменить порядок следования цифр числа n на обратный.

+3
Ответы (1)
  1. 2 сентября, 18:35
    0
    program reverse1;

    var s, m, n:integer;

    begin

    writeln ('Введите число');

    readln (n);

    s: = 0;

    while n > 0 do

    begin

    //Находим остаток от деления числа на 10

    / / (в цикле получаются числа в обратном порядке).

    m: = n mod 10;

    //Остатки добавляются в конец нового числа.

    //При повторении цикла соответствующие числа перемещаются

    //в следующий разряд за счет умножения на 10.

    s: = s * 10 + m;

    n:=n div 10

    //Число делится на 10, чтобы при следующем прохождении

    //цикла найти остаток - цифру старшего разряда.

    end;

    writeln (s)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу в паскале: Дано натуральное число n. Заменить порядок следования цифр числа n на обратный. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Дано натуральное число. Верно ли, что количество его цифр есть четное число, а само число не превышает b? Написать программу на паскале используя циклы, но не используя массивы, строковый тип и boolean
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)
Надо написать программу на Паскале, без массивов. Дано натуральное число. Определить, сколько раз у этого числа встречается минимальная цифра. (Например, при вводе числа 2618319, на экране должно быть "2").
Ответы (1)