Задать вопрос

Ввести число если оно четное разделить его на 4 если не четное умножить на 5

+2
Ответы (1)
  1. 20 сентября, 19:08
    0
    Так как результат может быть дробным, например, при вводе 2, мы должны получить 0.5, то результат мы вынуждены хранить в вещественном типе данных.

    program Example;

    var

    a:integer;

    result:real;

    begin

    write ('Введите число ');

    readln (a);

    if (a mod 2) = 0 then result:=a/4 else result:=a*5;

    writeln ('Получим ', result);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Ввести число если оно четное разделить его на 4 если не четное умножить на 5 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Ввести число. Если оно четное, разделить его на 4, если нечетное-умножить на 5 (Паскаль)
Ответы (1)
Ввести 2 числа используя оператор ввода данных read (). Перед оператором read () обязательно вывести объяснения значения какой переменной надо ввести (Например, writeln ('vvedite a'); ). Ввести их через запятую.
Ответы (1)
ввести число ... если оно больше 8 разделить его на 4, если меньше или равно 8 то умножить на пять! if x>8 then y:=x/4 else y:=x*5
Ответы (1)
Ввести число от 5 до 9. Вывести его значение словом. Составить программу для решения приведенного ниже задания двумя способами, используя: а) команду выбора case; б) команду if. Ввести число от 5 до 9. Вывести его значение словом.
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)