Задать вопрос

Напишите программу, которая вводит натуральные числа а иб и выводит сумму квадратов натуральных чисел в диапазоне от а до б

+2
Ответы (1)
  1. 24 мая, 06:01
    0
    program sum_sqr;

    var a, b:integer;

    s:real;

    begin

    writeln ('Введите два числа через пробел');

    readln (a, b);

    if a > b then / /Если а больше b, тогда а и b обмениваются значениями

    begin

    s:=0;

    b:=b+a;

    a:=b-a;

    b:=b-a;

    end;

    for i: integer: = a to b do s: = s + power (i, 2);

    writeln (s)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая вводит натуральные числа а иб и выводит сумму квадратов натуральных чисел в диапазоне от а до б ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Напишите программу, которая вводит натуральные числа a и b и выводит все простые числа в диапазоне от a до b. Входные данные: Входная строка содержит два натуральных числа, a и b. Гарантируется, что a ≤ b.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
Написать программу на паскале, которая вводит массив из N целых случайных чисел, лежащих в диапазоне от 10 до 99 и выводит на экран элементы, кратные числу K.
Ответы (1)