Задать вопрос

Как написать программу для pascal abc которая считает факториал числа который вводит пользователь

+1
Ответы (1)
  1. 16 января, 10:09
    0
    program zz1;

    var n:integer; / / задаем переменные целого типа

    i:real;

    function fact (x:integer) : integer; / / описываем функцию для вычисления факториала

    var v, p:integer; / / описываем локальные переменные

    begin

    p:=1;

    for v:=1 to x do

    begin

    p:=p*v;

    end;

    fact:=p; / / присваиваем результат

    end;

    begin

    write (' введите число n '); / / вводим с клавиатуры число

    read (n);

    i:=fact (n); / / вычисляем факториал с использованием функции вычисления факториала

    write (' факториал заданного числа = ', i); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Как написать программу для pascal abc которая считает факториал числа который вводит пользователь ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Написать программу. Условие задачи: Написать программу вывода на экран лесенкой трех последовательно идущих трехзначных чисел. Первое число вводит пользователь, остальные вычисляются в программе. Пример работы программы: 213 214 215
Ответы (1)
Пользователь вводит число N программа считает сумму четных чисел до N и сумму не четных чисел до N. Написать алгоритм решения
Ответы (1)
Написать программу, которая принимает от пользователя количество числовых значений (указывает сам пользователь) для переменной и считает количество введенных трехзначных чисел, если учитывать, что вводиться могут числа в диапазоне от 0 до 10000 (по
Ответы (1)
На языке программирования Pascal реализовать следующие задачи: 1) Даны 2 переменные, в которые пользователь вводит два случайных числа.
Ответы (1)