Задать вопрос
31 августа, 09:22

Дана матрица NxN, состоящая из нулей и единиц. Нужно подсчитать количество единиц в ней.

+2
Ответы (1)
  1. 31 августа, 09:37
    0
    program zz1;

    const n = 4; / / задаем количество элементов в массиве

    var i, j, k:integer; / / задаем переменные целого типа

    a:array [1 ... n, 1 ... n] of integer;

    begin

    for i:=1 to n do

    for j:=1 to n do / / получаем числа и записываем их в массив

    a[i, j]:=random (2);

    for i:=1 to n do / / выводим полученный массив на экран

    begin

    for j:=1 to n do

    write (a[i, j]:4);

    writeln;

    end;

    for i:=1 to n do

    for j:=1 to n do

    if a[i, j] = 1 then k:=k + 1; / / проверяем, если элемент равен единице, то считаем его

    writeln (' количество элементов массива равных единице = ', k); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана матрица NxN, состоящая из нулей и единиц. Нужно подсчитать количество единиц в ней. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
Дана матрица 10x14, заданная случайными числами на интервале [-180; 320]. Подсчитать количество элементов больших, чем заданное число, выделить их светло-зеленым цветом.
Ответы (1)
1) Сколько значащих нулей в двоичной записи десятичного числа 503? 2). Для каждого из перечисленных ниже десятичных чисел построили двоичную запись. Укажите число, двоичная запись которого содержит наибольшее количество значащих нулей.
Ответы (1)
Дана квадратная матрица а размером n*n состоящая из действительных элементов. Найти среднее арифметическое из всех отрицательных элементов этой матрицы
Ответы (1)
1) Вывести массив 4*4 1 3 5 7 1 3 5 7 1 3 5 7 1 3 5 7 2) Массив 4*4 0010 0100 0000 1100 Подсчитать количество нулей и единиц 3) Случайным образом вывести массив 5*5 (50) A[I, j]: = random (50); Сумму элементов массива
Ответы (1)