Задать вопрос
5 апреля, 23:22

1) Даны круг и квадрат. Составьте программу, определяющую по введенным вами значениями длин стороны квадрата и радиус круга, одно из утверждений " Квадрат вписан в круг"

+5
Ответы (1)
  1. 6 апреля, 01:28
    0
    program zz1;

    var a, r:real; / / задаем переменные не целого типа

    begin

    write (' введите длину стороны квадрата '); / / вводим с клавиатуры заданную сторону квадрата

    read (a);

    write (' введите радиус круга '); / / вводим с клавиатуры заданный радиус круга

    read (r);

    if r < a * sqrt (2) / 2 / / проверяем по формуле описанной окружности

    then write (' Квадрат не вписан в круг ') / / выводим ответ

    else write (' Квадрат вписан в круг ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Даны круг и квадрат. Составьте программу, определяющую по введенным вами значениями длин стороны квадрата и радиус круга, одно из ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего - в куб и нахождения среднего арифметического полученных значений. 2.
Ответы (1)
Составьте программу которая по трем введенным вами числам определит могут ли эти числа быть длинами сторон треугольника и если да то определить вид этого треугольника
Ответы (1)
Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до 20 и вычисляет произведение элементов массива с чётными значениями и среднее арифм. элементов массива с нечётными значениями
Ответы (1)
Даны площадь S1 круга и площадь S2 квадрата определите поместиться ли круг в квадрат. Напишите программу на паскале
Ответы (1)
Напишите программу, которая по введённым с клавиатуры числам e, f и g будет вычислять значение коэффициентов a, b и c квдратного уравнения по предлагаемым формулам, а также значение дискриминанта D, решать это квадратное уравнение и выдавать
Ответы (1)