Задать вопрос

Составить алгоритм и написать программу на паскале нахождение разности цифр 4-х значного числа

+1
Ответы (1)
  1. 11 июля, 21:56
    0
    Чтобы выделить каждую цифру разряда четырехзначного числа, мы, во-первых, вводим четыре переменных для того, чтобы в них были записаны разряды числа.

    Так как из разряда тысяч мы будем вычитать разряд сотен, разряд десятков и разряд единиц, то порядок записи важен.

    Во-вторых, нам нужно перевести число в строку с помощью функции str ().

    Далее, по одному символу записываем разряды в переменные, снова переводим их в тип integer и вычитаем.

    Записываем результат.

    var a, b, c, d, num, i:integer;

    q, w, e, r, strn:string;

    begin

    num:=9123;

    Str (num, strn);

    q:=strn[1];

    w:=strn[2];

    e:=strn[3];

    r:=strn[4];

    val (q, a, i);

    val (w, b, i);

    val (e, c, i);

    val (r, d, i);

    writeln (a-b-c-d);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить алгоритм и написать программу на паскале нахождение разности цифр 4-х значного числа ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составьте алгоритм вычисления суммы всех натуральных чисел, не привышающих заданного натурального числа N. Проверьте алгоритм трассировкой. Напишите программу в Паскале.
Ответы (1)
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Написать программу в паскаль "найти сумму цифр сколь угодно значного целого числа". Использовать string
Ответы (1)
1) Вводится 4 числа. Вывести на экран наибольшую из первых цифр заданных чисел. Например, если a=46, b=831, c=2996, d=486, то напечатать число 8. Использовать процедуру. - Написать на Паскале. 2) Дан массив A (10,5).
Ответы (1)