Задать вопрос

Написать программу на языке С+ + Задача: В одной старинной задаче мудрец предложил шаху в качестве награды за услугу выдать зерно. Причем количество зерна оговорил так: на первую клетку шахматной доски положить 1 зерно, на 2-ую - 2, на 3-ю - 4, на 4-ую - 8 и т. д. Составить программу, с помощью которой можно вычислить, на какой клетке суммарное количество зерен превысит N штук.

+4
Ответы (1)
  1. 10 июня, 13:57
    0
    var n, i: integer; k: real; begin write ('Введите количество зёрен: '); readln (n); k : = 0; while k < = n do begin i : = i + 1; k : = k + power (2, i - 1); end; writeln ('На первых ', i, ' клетках, сумма зерен больше чем ', (n), ', там их: ', k); end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу на языке С+ + Задача: В одной старинной задаче мудрец предложил шаху в качестве награды за услугу выдать зерно. Причем ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Определить: за какой месяц величина ежемесячного увеличения вклада превысит 30 руб.
Ответы (1)
Шахматная ладья ходит по горизонтали или вертикали. Даны две различные клетки шахматной доски, определите, может ли ладья попасть с первой клетки на вторую одним ходом.
Ответы (1)
Написать программу ввода массива до тех пор, пока сумма введенных элементов не превысит числа 100. На Паскале
Ответы (1)
написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число, выбранное ПК и новое, полученное после
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)