Задать вопрос

Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Определить: за какой месяц величина ежемесячного увеличения вклада превысит 30 руб.; через сколько месяцев размер вклада превысит 1200 руб. (Pascal ABC)

+1
Ответы (1)
  1. 21 ноября, 22:59
    0
    program deposit;

    var p, s: real;

    n:integer;

    begin

    p:=0; //величина прибавки

    s:=1000; //первоначальная сумма

    n:=0; //число месяцев

    while p<=30 do / /пока прибавка меньше 30 руб.

    begin

    p:=s*0.02; / /величина месячной прибавки

    s:=s+p; / / прошлая сумма плюс прибавка за текущий месяц

    n:=n+1; //число месяцев

    end;

    writeln ('Ежемесячное увеличение вклада превысит 30 руб через ', n, ' месяцев');

    n:=0; / /обнуление счетчика месяцев

    s:=1000; //восстановление значения первоначального взноса

    while s<=1200 do

    begin

    p:=s*0.02; //Величина месячной прибавки

    s:=s+p; //прошлая сумма плюс прибавка за текущий месяц

    n:=n+1; //число месяцев

    end;

    writeln ('Величина вклада превысит 1200 руб через ', n,' месяцев');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Чем отличается Turbo Pascal от Pascal ABC?
Ответы (1)
Во время уценки цена всех товаров, которых хранятся на складе более 6 месяцев, снижается на 20% (если цена товара больше 1000 рублей) или на 10% (если цена меньше 1000 рублей). А В С D 1 Код Цена, руб. Хранится (месяцев) Новая цена, руб.
Ответы (1)
Линейный массив содержит сведения о количестве осадков, выпавших за каждый из 12 месяцев одного года. Составить программу, определяющую общее количество осадков за этот год, среднемесячное количество осадков, количество засушливых месяцев (когда
Ответы (1)
В банк был положен вклад в размере N рублей. Каждый месяц он увеличивался на 1%. Определить размер вклада через 5 лет
Ответы (1)
Лыжник пробежал в 1 день 10 км, каждый следующий день он пробегал на 10% больше. Определить в какой день он пробежит 20 км, в какой день суммарны пробег превысит 200 км Решить в Паскале
Ответы (1)