Задать вопрос

Наибольший общий делитель (НОД) двух или нескольких чисел - это наибольшее число, на которое делятся все заданные числа. Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Паскаль ABC

+2
Ответы (1)
  1. 24 июля, 15:16
    0
    Program zz1;

    Var a, b:integer; / / задаем переменные целого типа

    Function Nod (a, b:integer) : integer; / / вспомогательный алгоритм

    Begin

    While ab do / / организуем цикл, пока исходные два числа не равны между собой

    if a>b / / проверяем условие, если первое число больше второго

    then a:=a-b / / то, от первого отнимаем второе

    else b:=b-a; / / иначе, от второго отнимаем первое

    Nod:=a; / / в связи с тем, что по окончании цикла два числа сравняются, ответом является любое из них

    End;

    begin

    write (' Введите два числа '); / / вводим с клавиатуры заданные числа

    readln (a, b);

    writeln (' НОД двух исходных чисел = ', Nod (a, b));

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Наибольший общий делитель (НОД) двух или нескольких чисел - это наибольшее число, на которое делятся все заданные числа. Напишите ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Написать программу, которая вычисляет наибольший общий делитель двух целых чисел Паскаль
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
Установите соответствие. График Служит для сравнения нескольких величин в нескольких точках Круговая диаграмма Позволяет отслеживать динамику изменения данных Столбчатая диаграмма Позволяет наглядно сравнить суммы нескольких величин в нескольких
Ответы (1)
1) Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.2) Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.
Ответы (1)