Задать вопрос
23 декабря, 11:11

Найти произведение положительных, сумму и количество отрицательных из 10 введенных целых чисел

+4
Ответы (1)
  1. 23 декабря, 15:05
    0
    program zz1;

    var a, b, n, i, k:integer; / / задаем переменные целого типа

    begin

    b:=1;

    for i:=1 to 10 do

    begin

    read (a); / / вводим число

    if a > 0 then b:=b * a; / / проверяем, если число больше нуля, то умножаем его на произведение

    if a < 0 then n:=n + a; / / проверяем, если число меньше нуля, то добавляем его в сумму

    if a < 0 then k:=k + 1; / / проверяем, если число меньше нуля, то считаем его

    end;

    writeln (' произведение положительных = ', b); / / выводим ответы

    writeln (' сумма отрицательных = ', n);

    writeln (' количество отрицательных = ', k);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти произведение положительных, сумму и количество отрицательных из 10 введенных целых чисел ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
Задача в паскале среди 10 введенных с клавиатуры чисел подсчитать количество отрицательных и произведение положительных чисел рассмотреть случай когда положительных чисел нет
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)