Задать вопрос

Найти: Сумму кубов всех целых чисел от 1 до n (Значение n вводится с клавиатуры; B>a)

+4
Ответы (1)
  1. 20 августа, 03:21
    0
    program zz1;

    var n, i, m, s:integer; / / задаем переменные целого типа

    begin

    write (' введите заданное число n '); / / вводим с клавиатуры последнее число ряда

    read (n);

    for i:=1 to n do / / организуем цикл, в котором переберем числа от единицы до n

    begin

    s:=s + i * i * i; / / возводим очередное число в куб, умножив на себя два раза, и добавляем его в сумму

    end;

    write (' сумма кубов всех целых чисел от 1 до n = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти: Сумму кубов всех целых чисел от 1 до n (Значение n вводится с клавиатуры; B>a) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напечатать "столбиком": а) все целые числа от 20 до 35; б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b > (или равно) 10); в) третьи степени всех целых чисел от a до 50 (значение а вводится с клавиатуры; а (или равно) а).
Ответы (1)
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)
Составьте программу вычисляющую, сумму квадратов чисел от 1 до n, (n - вводится с клавиатуры) если n-четное, и сумму кубов чисел от 1 до n, если n-нечетное. Использовать цикл WHILE
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
1. Найти s=1+1/2 + 1/3 + 1/4 + ...+1/n, n - вводится с клавиатуры 2. Найти сумму N чисел, вводимых с клавиатуры.
Ответы (1)