Задать вопрос

Дан целочисленный массив из 10 элементов. Написать программу, находящую сумму элементов массива кратных 3 или 5?

+2
Ответы (1)
  1. 27 января, 17:47
    0
    Решение задачи на языке C++

    #include

    #include

    using namespace std;

    void main ()

    {

    setlocale (LC_ALL, "rus");

    srand (time (0));

    int const N = 10;

    int mas[N], sum=0;

    cout << "Элементы массива: " << endl;

    for (int i = 0; i < N; i++)

    {

    mas[i] = rand () % 100;

    cout << mas[i] << " ";

    if (mas[i] % 3 = = 0 || mas[i] % 5==0)

    {

    sum + = mas[i];

    }

    }

    cout << endl << "Сумма элементов кратных 3 или 5: "<
    system ("pause");

    }
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан целочисленный массив из 10 элементов. Написать программу, находящую сумму элементов массива кратных 3 или 5? ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Дан целочисленный массив из 2000 элементов. Если сумма всех элементов массива чётная, нужно вывести количество нечётных (по значению) элементов массива, если нечётная - количество чётных.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
Дан целочисленный массив из 30 элементов. Элементы массива могут принимать значения от 0 до 1000. Напишите программу, позволяющую найти и вывести количество элементов массива, кратных трём, запись которых заканчивается цифрой 1. Паскаль АБС
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)