Задать вопрос

Определите значения переменных X, Y, Z после выполнения следующего фрагмента программы: Х: = 3; Y: = 7; Z: = 11; X: = Y+Z; Z: = X+Z; Y: = Y+X; X: = Y-X; X: = X*Z; Z: = Y+Z;

+2
Ответы (1)
  1. 11 августа, 13:55
    0
    Значения переменных после каждого шага программы:

    Х: = 3;

    Y: = 7;

    Z: = 11;

    X: = Y + Z (X = 7 + 11 = 18);

    Z: = X + Z (Z = 18 + 11 = 29);

    Y: = Y + X (Y = 7 + 18 = 25);

    X: = Y - X (X = 25 - 18 = 7);

    X: = X * Z (X = 7 * 29 = 203);

    Z: = Y + Z (Z = 25 + 29 = 54).

    Значения переменных после выполнения фрагмента: x = 203, y = 25, z = 54.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Определите значения переменных X, Y, Z после выполнения следующего фрагмента программы: Х: = 3; Y: = 7; Z: = 11; X: = Y+Z; Z: = X+Z; Y: = ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a: = 42; b: = 14; a:=a div b; b:=a*b a:=b div a 2) Определите значение целочисленных переменных x, y и t и b после выполнения фрагмента программы: x:=5; y:=7;
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)