Задать вопрос

Напишите программу на паскаль Заполните массив случайными числами в интервале [0,5]. Введите число X и найдите все значения равные x

+1
Ответы (1)
  1. 26 января, 20:36
    0
    Program Massiv;

    var A:array [0 ... 5] of integer; i, x:integer;

    begin

    writeln ('Введите цифру, которую нужно найти в массиве');

    readln (x);

    writeln ('Заполняем массив, с помощью оператора random');

    for i:=1 to 5 do

    begin

    A[i]:=random (5);

    writeln (A[i]);

    end;

    writeln ('Находим какой элемент массива соответсвует своему значению и значению искомого числа, если такое число есть ');

    for i:=1 to 5 do

    if x=A[i] then writeln ('A[', i,']=', x);

    end.

    вывод:

    Введите цифру, которую нужно найти в массиве

    2

    Заполняем массив, с помощью оператора random

    0

    2

    0

    1

    4

    Находим какой элемент массива соответсвует своему значению и значению искомого числа, если такое число есть

    A[2]=2
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу на паскаль Заполните массив случайными числами в интервале [0,5]. Введите число X и найдите все значения равные x ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Помогите написать программу в паскале. Заполните массив из N элементов случайными числами в интервале [1, N] так, чтобы в массив обязательно вошли все числа от 1 до N (постройте случайную перестановку). Пример: Массив: 3 2 1 4 5
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
Напишите программу, в которой массив из 10 элементов заполняется случайными вещественными числами на интервале [10, 40)
Ответы (1)
Заполнить массив из 10 элементов случайными числами в интервале [0 ... 4] и вывести номера всех элементов, равных X. Пример работы программы: Исходный массив: 4 0 1 2 0 1 3 4 1 0 Что ищем? 0 A[2], A[5], A[10]
Ответы (1)