Задать вопрос
10 января, 07:27

Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат.

+2
Ответы (1)
  1. 10 января, 07:56
    -1
    program zz1;

    var x1, x2, y1, y2, rast1, rast2:real; / / задаем переменные не целого типа

    begin

    write (' введите координаты первой точки '); / / вводим с клавиатуры координаты первой точки

    read (x1, y1);

    write (' введите координаты второй точки '); / / вводим с клавиатуры координаты второй точки

    read (x2, y2);

    rast1:=sqrt (sqr (x1-0) + sqr (y1-0)); / / находим расстояние от первой точки до начала координат

    rast2:=sqrt (sqr (x2-0) + sqr (y2-0)); / / находим расстояние от второй точки до начала координат

    if rast1 < rast2 then write (' первая точка ближе ') else write (' вторая точка ближе '); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Какие целые числа за числами: а) 101011 - в двоичной системе счисления б) 7777 - в восьмеричной системе счисления в) CDEF - в шестнадццатеричной системе счисления 2.
Ответы (1)
Составьте программу для решения задачи: даны две точки, заданные своими координатами. Определить, какая из них находится ближе к началу координат.
Ответы (1)
Даны координаты двух точек A (x1, y2) и B (x2, y2) в прямоугольной системе координат. Какая из этих двух точек находится дальше от начала координат?
Ответы (1)
Даны две точки на плоскости. Запишите алгоритм, позволяющий определить, какая из них находится ближе к началу координат. Способ записи выберите самостоятельно.
Ответы (1)
1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего - в куб и нахождения среднего арифметического полученных значений. 2.
Ответы (1)