Задать вопрос

Даны координаты двух точек A (x1, y2) и B (x2, y2) в прямоугольной системе координат. Какая из этих двух точек находится дальше от начала координат?

+5
Ответы (1)
  1. 28 августа, 22:04
    0
    program zz1;

    var x1, x2, y1, y2, rast1, rast2:real; / / задаем переменные не целого типа

    begin

    write (' введите координаты первой точки '); / / вводим с клавиатуры координаты первой точки

    read (x1, y1);

    write (' введите координаты второй точки '); / / вводим с клавиатуры координаты второй точки

    read (x2, y2);

    rast1:=sqrt (sqr (x1-0) + sqr (y1-0)); / / находим расстояние от первой точки до начала координат

    rast2:=sqrt (sqr (x2-0) + sqr (y2-0)); / / находим расстояние от второй точки до начала координат

    if rast1 > rast2 then write (' первая точка дальше ') else write (' вторая точка дальше '); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны координаты двух точек A (x1, y2) и B (x2, y2) в прямоугольной системе координат. Какая из этих двух точек находится дальше от начала ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Какие целые числа за числами: а) 101011 - в двоичной системе счисления б) 7777 - в восьмеричной системе счисления в) CDEF - в шестнадццатеричной системе счисления 2.
Ответы (1)
Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат.
Ответы (1)
Выполнить сложение в восьмеричной системе счисления 238+758 результат представить в двоичной системе счисления Выполнить сложение в шестнадцатеричной системе счисления 1416+3 В16. результат представить в двоичной системе счисления
Ответы (1)
411 в десятиричной системе + 111011 в двоичной системе + 444 в восьмеричной системе + AEFO2 в шестнадцетиричной = Х в десятиричной системе
Ответы (1)
Даны два числа первое в системе счисления с основанием три, второе в системе счисления с основанием четыре. Найдите их сумму и ответ запишите в системе счисления с основанием 16. 12012 (с основанием 3) + 10302 (с основанием 4) =
Ответы (1)