Задать вопрос

Вычислить сумму ряда чисел 1+1/2+1/3 + ... + 1/n, где n вводится пользователем

+2
Ответы (1)
  1. 31 августа, 00:33
    0
    Программа нахождения суммы ряда 1 + 1/2 + ... + 1/n

    Для выполнения программы нужно ввести целое число n.

    program calculate;

    var s: real;

    n, i:integer;

    begin

    S : = 0;

    Write ('Введите целое число n = ');

    readln (n);

    for i : = 1 to n do s : = s + 1/i;

    writeln ('Сумма ряда S = ', s:4:4)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вычислить сумму ряда чисел 1+1/2+1/3 + ... + 1/n, где n вводится пользователем ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу для вычисления примера a * (5+b) + 65 где переменная a и b вводится пользователем с клавиатуры причём эти переменные не должны быть больше 55
Ответы (1)
Вычислите сумму данных N натуральных чисел. Входные данные Вводится число N, а затем N чисел, сумму которых необходимо вычислить. Выходные данные Выведите единственное число - сумму введенных чисел. В Pascal ABC
Ответы (1)
Каждая бактерия делится на 2 через каждые 3 минуты. В начальный момент имеется 1 бактерия. Сколько их будет через n минут. N вводится пользователем. Составить программу с помощью цикла со счётчиком. (For счётчик:=нач.
Ответы (1)
1. Написать программу, которая вычисляет частное двух чисел. Программа должна проверять правильность введенных пользователем данных и, если они неверные (делитель равен нулю), вы давать сообщение об ошибке.
Ответы (1)
Вставь пропущенные слова: а) Назначение операционной системы: обеспечивает функционирование ... и программ, а также взаимодействие между ... и пользователем. б) Функции операционной системы: распределяет ... компьютера, управляет устройствами ...
Ответы (1)