Задать вопрос

1. Написать программу, которая вычисляет частное двух чисел. Программа должна проверять правильность введенных пользователем данных и, если они неверные (делитель равен нулю), вы давать сообщение об ошибке. Ниже приведен рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом). Вычисление частного. Введите в одной строке делимое и делитель, затем нажмите.-> 12 ОВы ошиблись. Делитель не должен быть равен нулю.

+2
Ответы (1)
  1. 10 ноября, 01:24
    0
    program zz1;

    var n, i:integer; / / вводим переменные целого типа

    begin

    writeln (' Вычисление частного: ');

    write (' Введите в одной строке делимое и делитель, затем нажмите - > '); / / вводим с клавиатуры два числа через пробел

    read (n, i);

    if i = 0 then write (' Вы ошиблись. Делитель не должен быть равен нулю. ') / / проверяем, если второе число равно нулю, то выводим один ответ

    else write (' Частное двух чисел = ', n/i); / / если второе число не равно нулю, то выводим другой ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Написать программу, которая вычисляет частное двух чисел. Программа должна проверять правильность введенных пользователем данных и, если ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составьте программу которая выводит на экран пример на умножение двух однозначных чисел, запрашивает ответ пользователя. проверяет его и выводит соответсвующиеся сообщения : "Правильно!" либо "Вы ошиблись". а также правильный результат.
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
В массиве хранятся сведения о количестве осадков, выпавших за 10 дней июня. Написать программу, которая определяет общее количество осадков за 10 дней. Массив должен вводиться во время работы программы.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)