Задать вопрос
11 июля, 01:28

Напишите программу, которая вводит натуральное число N и выводит на экран все автоморфные числа, не превосходящие N

+5
Ответы (1)
  1. 11 июля, 02:03
    0
    var

    n, i, r, l1: longint;

    s1, s2: string;

    begin

    write ('Введите натуральное число N: ');

    readln (n);

    writeln ('Автоморфные числа, не превосходящие число N: ');

    for i : = 1 to n do

    begin

    r : = sqr (i);

    str (i, s1);

    l1 : = length (s1);

    str (r, s2);

    if s1 = copy (s2, length (s2) - l1 + 1, l1) then writeln (i)

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая вводит натуральное число N и выводит на экран все автоморфные числа, не превосходящие N ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы