Задать вопрос
21 марта, 03:29

Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать). Сделайте три варианта программы, используя операторы While, Repeat, For.

+1
Ответы (1)
  1. 21 марта, 07:07
    0
    Первый вариант:

    Sum:=0;

    for i:=1 to n do

    begin

    Write ('a = ');

    ReadLn (a);

    Sum:=Sum+a;

    end;

    Sred:=Sum/n;

    Writeln ('Sred = ', Sred:6:2);

    ReadLn;

    end.

    Второй вариант:

    Sum:=0;

    i:=1;

    repeat

    Write ('a = ');

    ReadLn (a);

    Sum:=Sum+a;

    i:=i+1;

    until i>n;

    Sred:=Sum/n;

    Writeln ('Sred = ', Sred:6:2);

    WriteLn;

    Третий вариант:

    uses Crt;

    const n=10;

    var a, i, Sum: integer;

    Sred: real;

    begin

    ClrScr;

    Sum:=0;

    i:=1;

    While i<=10 do

    begin

    Write ('a = ');

    ReadLn (a);

    Sum:=Sum+a;

    i:=i+1;

    end;

    Sred:=Sum/n;

    Writeln ('Sred = ', Sred:6:2);

    WriteLn;
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Осуществить ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых положительных чисел. Использовать оператор repeat.
Ответы (1)
Составить алгоритм сложения двух целых чисел F и Q, вводимых с клавиатуры. Результат сложения записать в виде переменной W. По данному алгоритму написать программу в Паскале. алг сложение цел F, Q, W нач ввод F ввод Q W:=F+Q вывод W кон 2.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального (наибольшего) из введёных чисел. Используйте оператор repeat. Решить в паскале.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется пока не будет введен ноль) и определение максимального (наибольшего) из введенных чисел. И составить блок схему
Ответы (1)