Задать вопрос

Напишите процедуру которая принимает параметр - натуральное число N и выводит первые N чисел Фибоначчи

+5
Ответы (1)
  1. 10 октября, 00:13
    0
    program zz1;

    var a, b, n, c, i:integer; / / задаем переменные целого типа

    begin

    write (' введите натуральное число n '); / / вводим с клавиатуры число

    read (n);

    a:=1; b:=1; / / получаем первые числа Фибоначчи

    write (a, ' ', b, ' '); / / выводим их на экран

    i:=2;

    while i < n do / / организуем цикл, пока количество чисел Фибоначчи меньше чем заданное число N

    begin

    c:=a + b; / / получаем следующее число Фибоначчи

    write (c, ' '); / / выводим ответ

    a:=b;

    b:=c;

    i:=i + 1; / / увеличиваем счетчик

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите процедуру которая принимает параметр - натуральное число N и выводит первые N чисел Фибоначчи ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Ряд чисел Фибоначчи задается следующим образом: первые два числа равны 1 (F 1 = F 2 = 1), а каждое следующее равно сумму двух предыдущих: F i = F i - 1 F i - 2.
Ответы (1)
Числа Фибоначчи это числовая последовательность, в которой первые два числа единицы, а каждое последующее равно сумме двух предыдущих. Дано натуральное число N (2
Ответы (1)
Pascal ABC. Написать процедуру, которая выводит на экран первые 3 элемента из массива, которые не равны друг другу. Или процедуру нахождения 3 максимальных элементов массива, которые не равны друг другу
Ответы (1)
Дано целое число N (больше 1). Последовательность чисел Фибоначчи FK определяется следующим образом:F1 = 1, F2 = 1, FK = FK-2 + FK-1, F3=1+1=2. Проверить, является ли число N числом Фибоначчи
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)