Задать вопрос

Ряд чисел Фибоначчи задается следующим образом: первые два числа равны 1 (F 1 = F 2 = 1), а каждое следующее равно сумму двух предыдущих: F i = F i - 1 F i - 2. Напишите программу, которая вводит натуральное число N и заполняет массив из N элементов первыми N числами Фибоначчи. Входные данные Входная строка содержит размер массива N. Гарантируется, что 0 < N ≤ 40. Выходные данные Программа должна вывести содержимое массива: первые N чисел Фибоначчи. Примеры входные данные 5 выходные данные 1 1 2 3 5

+4
Ответы (1)
  1. 31 декабря, 01:53
    0
    Program vashurok1;

    var i, ch, ch1, ch2, n:integer;

    begin

    write ('n=');

    readln (n);

    ch:=0; ch1:=1;

    for i:=1 to n do begin

    ch2:=ch1;

    ch1:=ch;

    ch:=ch1+ch2;

    write (ch:4);

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Ряд чисел Фибоначчи задается следующим образом: первые два числа равны 1 (F 1 = F 2 = 1), а каждое следующее равно сумму двух предыдущих: F ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая заполняет массив первыми N натуральными числами и выводит его. Входные данные Входная строка содержит размер массива N. Гарантируется, что 0 < N ≤ 10000.
Ответы (1)
Напишите программу, которая вводит натуральные числа a и b и выводит все простые числа в диапазоне от a до b. Входные данные: Входная строка содержит два натуральных числа, a и b. Гарантируется, что a ≤ b.
Ответы (1)
С+ + Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)