Задать вопрос
10 августа, 14:39

У скольких натуральных чисел от 1 до 2 в степени N, где N = 10, сумма цифр кратна четырем? Комментарий. Например, для N=3N=3 рассматриваются такие числа: 1, 2, 3, 4, ..., 8. Сумма цифр кратна четырем у двух из них.

+1
Ответы (1)
  1. 10 августа, 17:26
    0
    Составим цикл нахождения количества чисел для языке программирования Pascal

    var i, i2, sum, ans:integer;

    s:string;

    begin

    for i:=1 to 1024 do

    begin

    sum:=0

    s:=IntToStr (i);

    for i2:=1 to length (s) do

    sum:=sum+StrToInt (s[i2]);

    if sum mod 4 = 0 then

    inc (ans);

    end;

    writeln (ans);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «У скольких натуральных чисел от 1 до 2 в степени N, где N = 10, сумма цифр кратна четырем? Комментарий. Например, для N=3N=3 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
У скольких натуральных чисел от 1 до 2 в степени 10 сумма цифр кратна четырем?
Ответы (1)
1) Составить программу нахождения суммы квадратов чисел от 25 до 125. 2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=
Ответы (1)
Напишите программу в паскаль! Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в K - ю степень (где K - количество цифр в числе) равна самому числу. Например, 153 = 1 3 + 5 3 + 3 3.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)